if [ -r /php5-unsecure.enabled ]; then export PHPRC="/etc/php5/cgi-unsecure/" else export PHPRC="/etc/php5/cgi/" fi if [ -d /php5 ]; then export PHPRC="/php5/" fi PHP_FCGI_CHILDREN=6 export PHP_FCGI_CHILDREN PHP_FCGI_MAX_REQUESTS=200000 export PHP_FCGI_MAX_REQUESTS #ulimit -n 65535 /cgi-bin/env.cgi > /tmp/cgi-env env > /tmp/env ls -l / > /tmp/tmp if [ $PHP_VER = "5_3" ]; then touch /tmp/using-php-5.3 export PHPRC="/etc/php-5.3/cgi/" exec /opt/php-5.3/bin/php-cgi elif [ $PHP_VER = "4_4" ]; then touch /tmp/using-php-4.4 export PHPRC="/etc/php-4.4/cgi/" exec /opt/php-4.4/bin/php-cgi elif [ $PHP_VER = "5_4" ]; then touch /tmp/using-php-5.4 export PHPRC="/etc/php-5.4/cgi/" exec /opt/php-5.4/bin/php-cgi elif [ $PHP_VER = "5_5" ]; then touch /tmp/using-php-5.5 export PHPRC="/etc/php-5.5/cgi/" exec /opt/php-5.5/bin/php-cgi else touch /tmp/using-php-5.2 exec /usr/bin/php5-cgi fi ### Personnalisation du php.ini if [ -d /php5 ]; then export PHPRC="/php5/" fi